Module Placement yields "Tool Experienced an Error" in main layout

I’ve finished a module design, with schematic and layout as a headerized test coupon. When attempting to place that module into the master board I’m designing, I’m taken to the “Map Layers” dialog where I either create new layers or assign to existent layers (I’ve tried both without success). After clicking “Map Layers” in this dialog, I get a “Tool experienced an Error” message and the browser reloads.

I’ve tried re-exporting the module, converting to design and back to module, etc with no success.

Doing the following didn’t help:

Yanking all layer pours
Pulling custom parts I created footprints for
Regenerating the module footprint
Creating a new empty project to import module into
Adding “,skip_constraints=true” to the end of the URL

Interestingly as well, when I attempted to download and reupload the same files using the .upv json format, upon upload I received the following error.

If you’re internally passing the module around in this manner, potentially the JSON is unreadable/malformed/corrupted?

Unexpected import error. | Traceback (most recent call last):
File “/home/ubuntu/builds/20190315220604/eggs/background_workers-201903180351_b3ef4cf2-py2.7.egg/background_workers/handlers/”, line 342, in work
File “/home/ubuntu/builds/20190315220604/eggs/background_workers-201903180351_b3ef4cf2-py2.7.egg/background_workers/handlers/”, line 888, in process
File “/home/ubuntu/builds/20190315220604/eggs/background_workers-201903180351_b3ef4cf2-py2.7.egg/background_workers/handlers/”, line 1012, in parse
File “/home/ubuntu/builds/20190315220604/eggs/background_workers-201903180351_b3ef4cf2-py2.7.egg/background_workers/handlers/”, line 2245, in parse_gen_objs
File “/home/ubuntu/builds/20190315220604/eggs/api_server-201903180350_b3ef4cf2-py2.7.egg/api_server/”, line 64, in pb_message_to_json
pb_message_to_json_inner_(message, fh)
File “/home/ubuntu/builds/20190315220604/eggs/api_server-201903180350_b3ef4cf2-py2.7.egg/api_server/”, line 70, in pb_message_to_json_inner_
pb_field_to_json(None, message, fh)
File “/home/ubuntu/builds/20190315220604/eggs/api_server-201903180350_b3ef4cf2-py2.7.egg/api_server/”, line 123, in pb_field_to_json
raise ValueError(‘unexpected type to encode as json’)
ValueError: unexpected type to encode as json

Without having having access to source, I’m limited with pursuing investigation. Here’s a potential breadcrumb wherein a known encoding mismatch between ascii (default) and UTF-8 encoded inputs may cause python to vomit:

Any news on this one? I’m unfortunately blocked on other work in Upverter until I can make use of modules.

This is really serious issue, I don’t understand why there’s no reaction!

Yeah I ended up completely dropping Upverter because of it. Moved over to KiCad instead since it has much better support as I never received a response to this (and is also free).

Yeah, I think most of us have realized Upverter left us out to dry.
Dead platform, 0 support.